  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://www.ifiberonenewsradio.com/content/tncms/live/" />
<meta name="keywords" content="sports" />
<meta name="news_keywords" content="sports" />
<meta name="description" content="RENTON, Wash. (AP) - The Seattle Seahawks are reuniting with another former pass rusher, agreeing to terms on a deal with defensive end Benson Mayowa. Mayowa's agent David Canter tweeted" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/9cc4cf34-db28-11e5-90e1-57a1d9baa526.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Here is the latest Washington, Oregon and Alaska sports news from The Associated Press" />
<meta property="og:description" content="RENTON, Wash. (AP) - The Seattle Seahawks are reuniting with another former pass rusher, agreeing to terms on a deal with defensive end Benson Mayowa. Mayowa's agent David Canter tweeted" />
<meta property="og:site_name" content="iFIBER ONE News Radio" />
<meta property="og:section" content="Sports" />
<meta property="article:publisher" content="https://www.facebook.com/1030KMAS?ref=tn_tnmn" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ifiberoneradio" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.c93c91680003c101b619d7dc5ab460f0.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/live/global/resources/styles/site.css?_dc=1456349022"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>/*<![CDATA[*/ #user-controls-447081 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-447081 .tn-user-screenname, #user-controls-447081 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-447081 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-447081 .dropdown-signup { font-size: 12px; } #user-controls-447081 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-447081 .large-user-avatar { margin-right: 10px; } #user-controls-447081 .large-user-controls { font-size: 12px; } #user-controls-447081 .logout-btn { cursor: pointer; } #user-controls-447081 .login-btn { color: #fff!important; } #block-447066 .search-spinner { position: absolute; } #block-447066 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-447066 { margin-bottom: 0; } #site-search-447066 .site-search-form { padding: 0; } #site-search-447066 #site-search-447066-btn { outline: none; } #site-search-447066 #site-search-447066-term { border: 0; box-shadow: none; } #site-search-447066 .site-search-form { box-shadow: none; } #tncms-block-463178 .tnt-prop-img { max-width: 201px; } #tncms-block-490420 .tnt-prop-img { max-width: 575px; } #block-446897 .search-spinner { position: absolute; } #block-446897 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-446897 { margin-bottom: 0; } #site-search-446897 .site-search-form { padding: 0; } #site-search-446897 #site-search-446897-btn { outline: none; } #site-search-446897 #site-search-446897-term { border: 0; box-shadow: none; } #site-search-446897 .site-search-form { box-shadow: none; } #tncms-block-556666 .tnt-prop-img { max-width: 345px; } #tncms-block-556706 .tnt-prop-img { max-width: 600px; } #user-controls-447080 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-447080 .tn-user-screenname, #user-controls-447080 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-447080 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-447080 .dropdown-signup { font-size: 12px; } #user-controls-447080 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-447080 .large-user-avatar { margin-right: 10px; } #user-controls-447080 .large-user-controls { font-size: 12px; } #user-controls-447080 .logout-btn { cursor: pointer; } #user-controls-447080 .user-welcome { color: #000000; } #user-controls-447080 .login-btn { color: #fff!important; } .follow-links-447067 li { margin-right: 1px; padding: 0; } .follow-links-447067 li a, .follow-links-447067 li a:focus, .follow-links-447067 li a:active { ; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-447067 li a:hover { text-decoration: none; opacity: 1; } .follow-links-447067 li a.fb,.follow-links-447067 li a.fb:hover { color: #3A59A5; } .follow-links-447067 li a.tw,.follow-links-447067 li a.tw:hover { color: #46C8F9; } .follow-links-447067 li a.yt,.follow-links-447067 li a.yt:hover { color: #CE2B29; } #block-447052 { color: #fff; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.162.0"},"page":{"grid":"boxy","style":"default","path":"\/sports","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":156},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"3ae8428e-74f1-11ea-8ab1-23539265b64e","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/ads/impressions.js?_dc=1585892114"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/ads/traffic.js?_dc=1585812913"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/ads/settings.js?_dc=1519927734"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1585202689"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1585202689"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Here is the latest Washington, Oregon and Alaska sports news from The Associated Press | Sports | ifiberonenewsradio.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://www.ifiberonenewsradio.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/9cbffc34-db28-11e5-90e0-23fdd28b7ccd.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Here is the latest Washington, Oregon and Alaska sports news from The Associated Press | Sports | ifiberonenewsradio.com" href="http://www.ifiberonenewsradio.com/search/?f=rss&amp;t=article&amp;c=sports&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            
<!-- code here -->

<script>
$(document).ready(function(){

$('#main-nav_menu > li > a[href = "/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"]').addClass(function(){
$(this).parent().addClass("myactive");
});
});
</script>

<script>
$(document).ready(function() {
        $(".navbar-default .navbar-nav > li > a:contains('Live TV')").addClass('red');
 });
</script>



        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-3ae8428e-74f1-11ea-8ab1-23539265b64e section-sports type-article infinity-disabled" data-path="/sports">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.ifiberonenewsradio.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.162.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fsports&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=156&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=3ae8428e-74f1-11ea-8ab1-23539265b64e&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.ifiberonenewsradio.com",
  secureDomain: "ifiberonenewsradio.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container">

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-447081" class="tncms-block hidden-md hidden-lg"><div id="user-controls-447081" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.ifiberonenewsradio.com/users/signup/?referer_url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.ifiberonenewsradio.com/users/login/?referer_url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.ifiberonenewsradio.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-447081').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ifiberonenewsradio.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ifiberonenewsradio.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ifiberonenewsradio.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-447081').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.ifiberonenewsradio.com/users/logout/" id="user-logout-form-447081"><input type="hidden" name="referer_url" value="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-south-sound">SOUTH SOUND</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/"  class="nav-link tnt-section-news">News</a>
                                </li><li>
                                    <a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                                </li><li>
                                    <a href="/daybreak/"  class="nav-link tnt-section-daybreak">Daybreak</a>
                                </li><li>
                                    <a href="/opinions/"  class="nav-link tnt-section-opinions">Opinions</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-more">...More</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://www.ifiberone.com/columbia_basin/"  target="_blank" rel="noopener" class="nav-link tnt-section-columbia-basin">COLUMBIA BASIN</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="http://www.ifiberone.com/columbia_basin/news/"  target="_blank" rel="noopener" class="nav-link tnt-section-news">News</a>
                                </li><li>
                                    <a href="http://www.ifiberone.com/columbia_basin/sports/"  target="_blank" rel="noopener" class="nav-link tnt-section-sports">Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://www.ifiberone.com/wenatchee/"  target="_blank" rel="noopener" class="nav-link tnt-section-wenatchee-valley">WENATCHEE VALLEY</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="http://www.ifiberone.com/wenatchee/news/"  target="_blank" rel="noopener" class="nav-link tnt-section-news">News</a>
                                </li><li>
                                    <a href="http://www.ifiberone.com/wenatchee/sports/"  target="_blank" rel="noopener" class="nav-link tnt-section-sports">Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/radio/"  class="nav-link tnt-section-live-radio">LIVE RADIO</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/radio/line_up/"  class="nav-link tnt-section-line-up">Line-Up</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-more">...MORE</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-447066" class="tncms-block hidden-md hidden-lg"><section id="block-447066" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-447066" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-447066" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-447066-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-447066-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-447066-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-447066').submit();
        return false;
    });

    $('#site-search-447066').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-447066 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-447066 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-447066-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-463178" class="tncms-block"><section id="block-463178" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/6eecdebe-356e-11e9-b285-9be10125d98c.png?resize=200%2C43 200w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/6eecdebe-356e-11e9-b285-9be10125d98c.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-south-sound"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">SOUTH SOUND</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/news/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/local_news/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-state-news"  href="/news/regional_state_news/" >
                    <span class="nav-label">Regional / State News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-environment-news"  href="/news/environment_news/" >
                    <span class="nav-label">Environment News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-recreation"  href="/news/recreation/" >
                    <span class="nav-label">Recreation</span>
                </a></li><li>
                <a class="nav-link  tnt-section-entertainment"  href="/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-2-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-broadcasts"  href="/sports/sports_broadcasts/" >
                    <span class="nav-label">Broadcasts</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-daybreak"  href="/daybreak/" >
                    <span class="nav-label">Daybreak</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinions"  href="/opinions/" >
                    <span class="nav-label">Opinions</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-2-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-adventures-with-dale-and-jerry"  href="/news/adventures_with_dale_and_jerry/" >
                    <span class="nav-label">Adventures with Dale and Jerry</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lost-found-pets"  href="/community/lost_found_pets/" >
                    <span class="nav-label">Lost & Found Pets</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-festivals"  href="/community/local_festivals/" >
                    <span class="nav-label">Local Festivals</span>
                </a></li><li>
                <a class="nav-link  tnt-section-public-service-links"  href="/community/public_service_links/" >
                    <span class="nav-label">Public Service Links</span>
                </a></li><li>
                <a class="nav-link  tnt-section-citizen-editorial"  href="/community/citizen_editorial/" >
                    <span class="nav-label">Citizen Editorial</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/community/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-more"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">...More</span>
                </a><ul id="main-nav_menu-child-2-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-politics"  href="/news/politics/" >
                    <span class="nav-label">Politics</span>
                </a></li><li>
                <a class="nav-link  tnt-section-public-notices"  href="/news/public_notices" >
                    <span class="nav-label">Public Notices</span>
                </a></li><li>
                <a class="nav-link  tnt-section-accounting-tax-news"  href="/news/accounting_tax_news/" >
                    <span class="nav-label">Accounting & Tax News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-voters-guide"  href="/news/voters_guide/" >
                    <span class="nav-label">Voters Guide</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-columbia-basin"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://www.ifiberone.com/columbia_basin/"  target="_blank" rel="noopener">
                    <span class="nav-label">COLUMBIA BASIN</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="http://www.ifiberone.com/columbia_basin/news/"  target="_blank" rel="noopener">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-3-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="http://www.ifiberone.com/columbia_basin/news/"  target="_blank" rel="noopener">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-news"  href="http://www.ifiberone.com/news/regional_news/"  target="_blank" rel="noopener">
                    <span class="nav-label">Regional News</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-sports"  href="http://www.ifiberone.com/columbia_basin/sports/"  target="_blank" rel="noopener">
                    <span class="nav-label">Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-wenatchee-valley"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://www.ifiberone.com/wenatchee/"  target="_blank" rel="noopener">
                    <span class="nav-label">WENATCHEE VALLEY</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="http://www.ifiberone.com/wenatchee/news/"  target="_blank" rel="noopener">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-4-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="http://www.ifiberone.com/wenatchee/news/"  target="_blank" rel="noopener">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-news"  href="http://www.ifiberone.com/news/regional_news/"  target="_blank" rel="noopener">
                    <span class="nav-label">Regional News</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-sports"  href="http://www.ifiberone.com/wenatchee/sports/"  target="_blank" rel="noopener">
                    <span class="nav-label">Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-live-radio"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/radio/" >
                    <span class="nav-label">LIVE RADIO</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-line-up"  href="/radio/line_up/" >
                    <span class="nav-label">Line-Up</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-more"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">...MORE</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
              
<div class="option-nav-bottom-container hidden-xs">
    <div class="container">
            <div class="row">
                <div class="col-lg-6 col-md-5"><div id="tncms-region-option-nav-bottom-left" class="tncms-region "><div id="tncms-block-490420" class="tncms-block"><section id="block-490420" class="block emphasis-h3   " ><div class="block">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/0a747646-59bf-11e6-bd6f-57e602a4e0c1.png?resize=200%2C17 200w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/0a747646-59bf-11e6-bd6f-57e602a4e0c1.png?resize=300%2C26 300w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/0a747646-59bf-11e6-bd6f-57e602a4e0c1.png?resize=400%2C35 400w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/0a747646-59bf-11e6-bd6f-57e602a4e0c1.png?resize=540%2C47 540w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/0a747646-59bf-11e6-bd6f-57e602a4e0c1.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></div></section></div></div></div>
                <div class="col-lg-3 col-md-4 hidden-xs hidden-sm"><div id="tncms-region-option-nav-bottom-middle" class="tncms-region "><div id="tncms-block-446897" class="tncms-block"><section id="block-446897" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-446897" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-446897" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-sm form-control">
        <input id="site-search-446897-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-446897-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-446897-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-446897').submit();
        return false;
    });

    $('#site-search-446897').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-446897 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-446897 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-446897-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                <div class="col-lg-3 col-md-3 hidden-xs hidden-sm"><div id="tncms-region-option-nav-bottom-right" class="tncms-region "><div id="tncms-block-556666" class="tncms-block"><section id="block-556666" class="block emphasis-h3   " ><div class="block"><a href="http://www.ifiberonenewsradio.com/radio/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/3b669862-3c11-11e7-9c3f-5765d36601db.jpg?resize=200%2C34 200w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/3b669862-3c11-11e7-9c3f-5765d36601db.jpg?resize=300%2C51 300w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/3b669862-3c11-11e7-9c3f-5765d36601db.jpg 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
            </div>
    </div>
</div>

        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-556706" class="tncms-block hidden-lg"><section id="block-556706" class="block emphasis-h3   " ><div class="block"><a href="http://www.ifiberonenewsradio.com/radio/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/d4e4dbc2-3c0f-11e7-ba59-fb73377567f7.jpg?resize=200%2C34 200w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/d4e4dbc2-3c0f-11e7-ba59-fb73377567f7.jpg?resize=300%2C52 300w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/d4e4dbc2-3c0f-11e7-ba59-fb73377567f7.jpg?resize=400%2C69 400w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/d4e4dbc2-3c0f-11e7-ba59-fb73377567f7.jpg?resize=540%2C93 540w, https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/d4e4dbc2-3c0f-11e7-ba59-fb73377567f7.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-474284" class="tncms-block"><section id="block-474284" class="block emphasis-h3   " ><div id="html-asset-474284">
            <div class="html-content">
<script data-ad-client="ca-pub-4957538467586213" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</div>
        </div></section></div><div id="tncms-block-446969" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-446968" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"","width":"1140","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-506538" class="tncms-block">
        <div id="blox-ad-position-Daybreak1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Daybreak","slot":"1","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-3ae8428e-74f1-11ea-8ab1-23539265b64e" class="asset article-default"  data-url="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/ifiberonenewsradio.com/content/tncms/custom/image/9cc4cf34-db28-11e5-90e1-57a1d9baa526.png">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="ifiberonenewsradio.com">
    </div>
    <link itemprop="mainEntityOfPage" href="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" />
    <style>
                .asset-paging .direction {
                    color: #bf0f0f;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"http:\/\/www.ifiberonenewsradio.com\/tncms\/search\/mlt\/?origin=3ae8428e-74f1-11ea-8ab1-23539265b64e&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-3ae8428e-74f1-11ea-8ab1-23539265b64e" class="asset-paging">
                <div id="paging-prev-3ae8428e-74f1-11ea-8ab1-23539265b64e" class="paging-link prev offset"></div>
                <div id="paging-next-3ae8428e-74f1-11ea-8ab1-23539265b64e" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Here is the latest Washington, Oregon and Alaska sports news from The Associated Press
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-04-02T07:50:00-07:00" class="tnt-date asset-date text-muted">
            Apr 2, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-04-02T07:50:00-07:00" class="tnt-date asset-date text-muted">
            Apr 2, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-04-02T07:50:17-07:00" class="tnt-date asset-date text-muted">14 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-04-02T07:50:00-07:00">
    <meta itemprop="datePublished" content="2020-04-02T07:50:00-07:00">
    <meta itemprop="dateModified" content="2020-04-02T00:50:17-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&via=ifiberoneradio&url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ifiberonenewsradio.com/tncms/asset/editorial/3ae8428e-74f1-11ea-8ab1-23539265b64e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bifiberonenewsradio.com%5D%20Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&body=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="3ae8428e-74f1-11ea-8ab1-23539265b64e">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&via=ifiberoneradio&url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ifiberonenewsradio.com/tncms/asset/editorial/3ae8428e-74f1-11ea-8ab1-23539265b64e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bifiberonenewsradio.com%5D%20Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&body=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-3ae8428e-74f1-11ea-8ab1-23539265b64e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="3ae8428e-74f1-11ea-8ab1-23539265b64e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="3ae8428e-74f1-11ea-8ab1-23539265b64e" class="save-list-3ae8428e-74f1-11ea-8ab1-23539265b64e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="3ae8428e-74f1-11ea-8ab1-23539265b64e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>RENTON, Wash. (AP) - The Seattle Seahawks are reuniting with another former pass rusher, agreeing to terms on a deal with defensive end Benson Mayowa. Mayowa's agent David Canter tweeted the sides reached an agreement Wednesday. NFL Network reported its a one-year deal. Mayowa is the second former Seahawks pass rusher being brought back for another opportunity. The Seahawks agreed to a deal with former first-round pick Bruce Irvin in the opening days of free agency. Mayowa had a career-high seven sacks and three forced fumbles last season with the Raiders.</p><p>SEATTLE (AP) - Washington freshman Isaiah Stewart has declared for the NBA draft. Stewart's decision to leave Washington after one season was anticipated even before he set foot on campus. He arrived to huge expectations that he would further Washington's resurgence under coach Mike Hopkins but the season became a frustrating mix of underachievement by the team and close losses. Stewart was named to the All-Pac-12 first team after averaging 16.6 points and 8.7 rebounds in the regular season. The forward is projected as a mid-to-late first-round pick in the draft.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>SEATTLE (AP) - The Seattle Metropolitans were on the verge of winning their second Stanley Cup in three years in the spring of 1919. They never got to celebrate. Neither did the Montreal Canadiens, their opponent in the finals that year. The 1919 series was abandoned after five games due to an outbreak of the Spanish flu. Several Montreal players became ill and one eventually died. It was only one of two times since the Stanley Cup was first awarded that there was no champion.</p><p>LOS ANGELES (AP) - The law firm whose arguments critical of American women's players led to the resignation of U.S. Soccer Federation president Carlos Cordeiro has asked to withdraw from representing the federation in the lawsuit. Seyfarth Shaw made the request to U.S. District Court in Los Angeles. Members of the women's national team filed suit against the USSF last year under the Equal Pay Act and the Civil Rights Act of 1964. They want over $66 million in damages. In papers filed March 9 by Seyfarth Shaw, the USSF argued women's national team players had lesser skills and responsibilities than their male counterparts.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&via=ifiberoneradio&url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ifiberonenewsradio.com/tncms/asset/editorial/3ae8428e-74f1-11ea-8ab1-23539265b64e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bifiberonenewsradio.com%5D%20Here%20is%20the%20latest%20Washington%2C%20Oregon%20and%20Alaska%20sports%20news%20from%20The%20Associated%20Press&body=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"3ae8428e-74f1-11ea-8ab1-23539265b64e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-3ae8428e-74f1-11ea-8ab1-23539265b64e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="3ae8428e-74f1-11ea-8ab1-23539265b64e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="3ae8428e-74f1-11ea-8ab1-23539265b64e" class="save-list-3ae8428e-74f1-11ea-8ab1-23539265b64e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="3ae8428e-74f1-11ea-8ab1-23539265b64e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="3ae8428e-74f1-11ea-8ab1-23539265b64e" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="3ae8428e-74f1-11ea-8ab1-23539265b64e" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc realnames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.ifiberonenewsradio.com/users/login/?referer_url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-447080" class="tncms-block"><div id="user-controls-447080" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.ifiberonenewsradio.com/users/signup/?referer_url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.ifiberonenewsradio.com/users/login/?referer_url=http%3A%2F%2Fwww.ifiberonenewsradio.com%2Fsports%2Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%2Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.ifiberonenewsradio.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-447080').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ifiberonenewsradio.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ifiberonenewsradio.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ifiberonenewsradio.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-447080').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.ifiberonenewsradio.com/users/logout/" id="user-logout-form-447080"><input type="hidden" name="referer_url" value="http://www.ifiberonenewsradio.com/sports/here-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press/article_3ae8428e-74f1-11ea-8ab1-23539265b64e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-447016" class="tncms-block"></div><div id="tncms-block-517522" class="tncms-block">
        <div id="blox-ad-position-Sales Ad1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Sales Ad","slot":"1","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-447062" class="tncms-block"></div><div id="tncms-block-446803" class="tncms-block hidden-xs">
        <div id="blox-ad-position-Floating-big-ad-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Floating-big-ad-middle","slot":"1","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-460505" class="tncms-block hidden-xs">
        <div id="blox-ad-position-Floating-big-ad-middle2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Floating-big-ad-middle","slot":"2","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-461193" class="tncms-block hidden-xs">
        <div id="blox-ad-position-Floating-big-ad-middle3" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Floating-big-ad-middle","slot":"3","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-461195" class="tncms-block hidden-xs">
        <div id="blox-ad-position-Floating-big-ad-middle4" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Floating-big-ad-middle","slot":"4","fold":"","width":"336","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-447067" class="tncms-block"><div class="follow-links-447067 pull-right">
    
    <section id="block-447067" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/1030KMAS?ref=tn_tnmn" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/ifiberoneradio" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCA7UyEhOcUlNaMbDETkVFfg" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.ifiberonenewsradio.com",
  "sameAs" : ["https://www.facebook.com/1030KMAS?ref=tn_tnmn","https://twitter.com/ifiberoneradio","https://www.youtube.com/channel/UCA7UyEhOcUlNaMbDETkVFfg"]
}
</script>
<div class="clearfix"></div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-446970" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"","width":"1140","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-447035" class="tncms-block"></div><div id="tncms-block-446971" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-447052" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-447052"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">ifiberonenewsradio.com</a>, 210 W. Cota St. Shelton, WA</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ifiberonenewsradio.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in',
                                message = document.getElementById('blox-message-incompatible');

                            Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                el.style.display = 'block';
                            });
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                            }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            <div id="blox-message-incompatible" class="notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox ad blocker" style="display:none;">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            Ads are being blocked by your browser.
        </h4>
        <p><strong>Please</strong> disable your ad blocker, whitelist our site, or <a class="alert-link" href="https://www.ifiberonenewsradio.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.ifiberonenewsradio.com%252Fsports%252Fhere-is-the-latest-washington-oregon-and-alaska-sports-news-from-the-associated-press%252Farticle_3ae8428e-74f1-11ea-8ab1-23539265b64e.html">purchase a subscription</a></p>
    </div>
</template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("3ae8428e-74f1-11ea-8ab1-23539265b64e")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script></body>
</html>